Departments
Brands
Top Brands
Brands You Follow
Stores
Nearby
You Visited
You Follow
You Search For
Topics
Hottests Topics
Catalogs
Featured Catalogs
People
Trendsetters
People Like You
Apps
Your apps
Discover apps
Get Advice
Top Questions
Your Q&A
Friends Asked
Ask A Question | Show All Questions
More on ShopYourWay
Manage My Life

My pressure Washer will not mix contents from the detergent dispenser. I tried everything! What can I try?

by Manage My Life Last activity date:
February 26th, 2009

I have a Sears model 75205 with on board deck/detergent wash cleaner tank. I have tried priming the surgical hose from the tank to the base of the engine. I tried sucking from an external bucket. Nothing works.

Tags:
Washers , Tools
Be the first to comment
Ask your friends
Answers (1)
Manage My Life
I can not pull up any information on the model number you sent.

The detergent draw on the pressure washer should not require priming to work. You did not send any information about if it used to work and now doesn't or if the pressure washer is new.

When the detergent dispenser doesn't draw detergent it is usually because detergent has dried in the check ball and spring area of the dispenser.

Unscrew the fitting the inlet tube attaches and take the spring and ball out. Clean the dispenser area and the ball and spring. Reassemble and it will usually work.

If you have further questions on the pressure washer, send the model number that is on the tag on the pressure washer.
by Manage My Life
February 26th, 2009
| Be the first to comment
0 votes
Add your own answer
Sign in to answer a question
Didn't find what you are looking for? Ask a question