?
Manage My Life

I have a Living Solutions Atomic Projection Alarm Clock time correct temp shows as ---

C17D3129(model #628123)


Tags
Appliances
Sign in to answer a question
3 Answers from these members:
GENE EDELMAN
Make sure you have good batteries in your wireless sensor. Press and hold snooze button for five seconds to synchronize the clock and the sensor. Red led on sensor will blink while communicating with the clock. Dashes on the clock will blink until it picks up the temp from sensor.
by GENE EDELMAN
March 6th
Comment
0 votes
Manage My Life
but it still isnt workingyes i have tried that
by Manage My Life
August 14th, 2011
Comment
0 votes
Wayne A
Have you tried relocating the remote sensor for the temperature sensor? The dashes being displayed is saying that the clock is not getting the signal from the sensor to determine the temperature reading. Try placing the sensor very near the clock to see that it will receive the signal.
by Wayne A
June 11th, 2009
Answered in 1 hours
Comment
0 votes
Didn't find what you are looking for? Ask a question