Departments
Brands
Top Brands
Brands You Follow
Stores
Nearby
You Visited
You Follow
You Search For
Topics
Hottests Topics
Catalogs
Featured Catalogs
People
Trendsetters
People Like You
Apps
Your apps
Discover apps
Get Advice
Top Questions
Your Q&A
Friends Asked
Ask A Question | Show All Questions
More on ShopYourWay
Manage My Life

My Cuisinart 14 cup stainless food processor will not start. What can be the problem?

by Manage My Life Last activity date:
January 15th, 2010

My one year old Cuisinart food processor (which worked fine the last time I used it) just sat there, making no attempt to start when I turned it on this time. I checked the power in the outlet and it is fine. All pieces of the unit are snapped into place correctly. I tried pushing a pen tip in the button that makes the connection when the lid is snapped in place thinking it might be a reset button, to no avail.

Tags:
Small Kitchen Appliances
Be the first to comment
Ask your friends
Answers (1)
Manage My Life
Without a model number I can only give you some general information on the food processor.

The plunger you pushed with a pen is a safety switch to keep you from starting the machine without the cover in place.

One of the safety switches or the main on and off switch might have failed. A wire might have broken or gotten disconnected inside the processor.

Someone will need to take the food processor apart and check the wiring with a meter to diagnose the problem.

I recommend you take the processor to a Sears Parts and Service Center or a Sears Retail Store for repair.
Answered in 19 hours
by Manage My Life
January 15th, 2010
| Be the first to comment
0 votes
Add your own answer
Sign in to answer a question
Didn't find what you are looking for? Ask a question