Skip to content
20% Or More Off Lawn & Garden Shop Now
Manage My Life

My Craftsman pressure washer won't start. Why?

It is a model 580.752100, 2700 PSI. New fuel was added.
Oil was added. The spark plug is good. It has a new air filter.
Starter fluid did not assist in the motor turning over.
It was sitting for over 1 year.

Craftsman , Washers , Pressure Washers
Sign in to answer a question
2 Answers from these members:
Manage My Life
You need to decide if the problem is no fuel or no spark.

Remove the spark plug and hold your finger or thumb on the hole the spark plug screws into. Get someone to pull the starter rope or engage the starter and the compression should push your finger off the spark plug hole. This will tell you the valves are operating inside the engine and you have compression.

Pour a thimble full of fuel into the hole the spark plug came out of. Quickly install the spark plug and pull the starter rope or engage the starter. The engine should try to start. This would tell you there is a spark and the engine will run if you get fuel. If the engine doesn't try to start, pour another thimble full of fuel into the cylinder. Look at the anode of the spark plug and see if it is wet. Try to start the engine again. If it still doesn't try to start, remove the spark plug and connect the ignition wire to the spark plug. Hold the bottom of the spark plug to a clean area on the engine block. Use insulated pliers or gloves to hold the spark plug to prevent shock. Get someone to pull the starter rope or engage the starter and see if you get a blue spark from the anode of the spark plug to the base of the plug. If there is no spark the ignition module on the engine is bad.

If you have spark the problem is in the fuel supply. Did you run the engine after draining the fuel to burn the fuel out of the carburetor? If not the carburetor will be clogged with the remnants of the old fuel and need to be replaced. If you ran the fuel out of the carburetor, the diaphragm or float is probably just dry and not flexing. You should take the carburetor apart and clean and soak the diaphragm with fuel or clean the float and needle and seat..

The fuel line might be cracked and letting air into it stopping the fuel from feeding the carburetor.

If you need more advice after trying these things, send another email and include the details of your tests and we will try to help.
by Manage My Life
March 16th, 2010
Answered in 20 hours
Brandie Tate
I followed your directions. Carb is clean and getting fuel. I replaced the gaskets plus needle and seat (it was dried and stuck open). Compression is good. I'm getting spark. I changed the oil twice, since it smelled like gas when I pulled it out of storage. I put in new fuel. Still the same result, it is trying to start but doesn't. Any more advice? Thanks in advance.
1 votes
what a great reply! The time and effort you put into covering the bases was impressive. My situation is that I have a spark, but fuel is not flowing. How do I find - and clean - the diaphragm, float, needle and seat you refer to?
by THOMAS WHITE Earned 7 community points in Craftsman
May 29th, 2014
0 votes
Didn't find what you are looking for? Ask a question
Get up to
% off
On Washers