Departments
Brands
Top Brands
Brands You Follow
Stores
Nearby
You Visited
You Follow
You Search For
Topics
Hottests Topics
Catalogs
Featured Catalogs
People
Trendsetters
People Like You
Apps
Your apps
Discover apps
Get Advice
Top Questions
Your Q&A
Friends Asked
Ask A Question | Show All Questions
More on ShopYourWay
Manage My Life

Oven in Jenn-Air range stopped working with no error codes.

by Manage My Life Last activity date:
November 24th, 2010

Last night I was going to bake something but when I tried to turn on my oven I got no response from key presses on the keypad. This is on a Jenn-Air JGS8850BDS gas slide-in range. The stove worked fine and the clock displayed like normal. No response from the "Bake", "Broil", "Setup", etc keys. Unplugged the range for about 5 minutes. When I plugged it back in I got a brief run of a fan (conv or cooling?) and the clock shows 12:00 and beneath that "Power Loss". The only keys on the keypad that seem to do anything are 1-6 keys. When these are pressed I get a double beep (and Power Loss goes away with the first of these keys). Other keys do nothing. No change in display and no beep.


I suspect it is the main board, but I guess it could be the keypad. Any advice on how to trouble-shoot this? Is there any source of technical information for the keypad, such as pin-outs for the ribbon cable to the main board?

Tags:
Ranges , Wall Ovens , Appliances
Be the first to comment
Ask your friends
Answers (5)
Joseph Perez
I understand how important it is for you to have a range that is working properly so that you can make a great meal. While you are waiting for an expert answer, I did manage to find a link that will provide you with more information about your problem. I hope my link is useful.
Answered in 15 minutes
by Joseph Perez
November 24th, 2010
| Be the first to comment
0 votes
answers
To view more answers
Join Now
it is free
Add your own answer
Sign in to answer a question
Didn't find what you are looking for? Ask a question