?
Manage My Life

Fuel line replacement for Craftsman chainsaw

The fuel line on my Craftsman chainsaw Model No. 358.350080 has rotted and was broken into pieces. I ordered a new fuel line and filter from Sears parts. I found a diagram on line but it is showing that the tubing from the small port on the primer bulb runs back to the fuel tank. I only see one hole in the fuel tank and that line goes from the fuel tank filter inside the tank to the carburator. Also I found a small white straight tubing connector in the fuel tank that had rotten tubing on each end. What is this connector for and where does it go?

Tags
Chain Saws , Craftsman , Kenmore PRO Appliances
Sign in to answer a question
2 Answers from these members:
Mark T
Thank you for your question.

I have checked the model number you have submitted. This saw has a fuel return line back to the fuel tank. I recommend putting a small amount of fuel in the tank then plug the one hole with your finger. Then tip the saw in every direction to see if any fuel leaks out. Please make sure to use extreme caution when doing this. This should help pin point the return whole in the tank. I found a video on YouTube video that shows the locations of the fuel line. Please click on this link to view the

video

. The connector is used to connect the fuel line from the tank to out side of the tank. I have provided you with an image below showing this.

Please reply below with more details if you need further assistance.

Here is a link to order any parts you need.

Sears Parts Direct

.

If you do not feel confident repairing this problem yourself, then you can have it repaired by a Sears technician. Here is a link that will provide the nearest drop-off locations:

Sears Home Services

.

Thank you for using Manage my life.

Mark T.
by Mark T Earned 1,607 community points in Craftsman
February 8th, 2011
Answered in 19 hours
Comment
0 votes
Joseph Perez
I know how important it is to have detailed instructions when replacing the fuel line on your chainsaw to make sure the line is installed properly. While you are waiting for an expert answer, I did manage to find a link that will provide you with more information about your problem. I hope my link is useful.
by Joseph Perez Earned 1,551 community points in Craftsman
February 7th, 2011
Answered in 6 minutes
Comment
0 votes
Didn't find what you are looking for? Ask a question