?
Manage My Life

Kenmore dehumidifier, Model number 580.54501800 still getting 'bucket full' after replacing the switch. Now what?.

Replaced the switch with new switch (part number 6600A30003C). Still displays the same error (01) and the bucket full lite is on. The bucket is not full. I removed the bucket and pressed the switch several times as recommended and get the same result..."bucket full" The humidifier is only two years old. The bucket has been emptied and replaced less than a dozen times. I have a hose connected to the dehumidifier so I don't really need the bucket. How can I get the dehumidifier to work? Not sure I want to spend a lot of money on what seems to be a very poor appliance. Your help and suggestions are appreciated.

Tags
Humidifiers , Kenmore , Appliances
Sign in to answer a question
4 Answers from these members:
scott d
Victor, if the switch and the board have been replaced, check the switch manually. A good check is to press the lever manually and listen for a clicking sound. If you do not hear this sound and since the switch has been replaced, the most likely problem will be that the actuator is not making contact with the switch. If you do hear this sound, it would lead back to the board. Another check will be with the float. Make sure the float is not stuck. If these checks are ok, I recommend taking this unit to the nearest repair center to have a tech check it.
by scott d Earned 3,139 community points in Kenmore
November 17th, 2012
Comment
Nicholas Wilkinson
I'm having the same problem. I think it may be the float. I took both lids off the bucket and the float looks like it's supposed to have to have two prongs that allow it to fit into holes in the top of the bucket. Mine only has one prong because the other must have broken off or worn down so it doesn't seat in the holes correct;y, making it not interact with the red switch correctly. Is it supposed to be making contact with the switch when it is full or when it is empty. I'm guessing full. If I just remove the float altogether, won't that fix my problem?
Nicholas Wilkinson
I removed the float and put the bucket back in but still same message. I also taped the switch so that it was depressed and put the bucket back in but still same error message.
0 votes
Manage My Life
I replaced the PCB board and still have the problem
by Manage My Life
November 15th, 2012
Comment
0 votes
scott d
I'm sorry you are having this problem. You have received some very good information. From the description of your problem, since the switch has been replaced, it appears the main PCB Assembly # EBR36909302 will have to be replaced. This board is available at Sears PartsDirect . Before replacing the board, make sure the unit is plugged into a properly grounded 3 prong outlet. If it doesn't have a ground connection, it can cause the board to react strangely. If you would like more assistance, any additional details will be helpful.

If you do not feel confident repairing this problem yourself, then you can have it repaired by a Sears technician. Here is a link that will provide the nearest drop-off locations:

Sears Home Services

.
by scott d Earned 3,139 community points in Kenmore
February 9th, 2011
Comment
0 votes
Joseph Perez
I understand your concern toward your dehumidifier displaying full bucket which means there may be something wrong with your appliance and I will be happy to help. While you are waiting for an expert answer, I did manage to find a link that will provide you with some good information about what may be wrong with your appliance. I hope my link is useful.
by Joseph Perez Earned 1,551 community points in Kenmore
February 7th, 2011
Answered in 5 minutes
Comment
0 votes
Didn't find what you are looking for? Ask a question