?
Manage My Life

Water level in a Kenmore ultrasoft 200 water softner

Hi i have a Kenmore ultrasoft 200 and the water is filling over the salt i have cleaned the nozzle and venture was wondering if there is anything else to do its from 1999

Tags
Kenmore , Appliances
Sign in to answer a question
8 Answers from these members:
Sam A
Thank you for the update. Yes this could very well be the problem. You can take the whole foot valve apart and clean it of any debris in the screens and check the o-rings.

Just make note of all the parts and where they go so you can put if back together correctly.

Sam A.
by Sam A Earned 707 community points in Appliances
October 11th, 2012
Comment
0 votes
Manage My Life
Yes when i pulled the float thing out of the tube it was stuck up amd wouldnt go down could that be it
by Manage My Life
October 11th, 2012
Comment
0 votes
Sam A
Thank you for the update on the leaking of the water softener.

You may have a leak in the resin tank. I would suggest removing all the salt and all the water and then pull the power plug on the softener. Then watch the salt tank for a couple of days to see if you get more water in the salt storage area.
If that proves to be the problem with the tank leaking, and because of the softeners age I would suggest replacing the softener, because of the cost of replacing the resin tank. You can use the model number which should start with 625.3XXXX and put it into Sears Parts direct to get a price on the resin tank for this model.

If it does not leak at the resin tank then the float valve could be the problem and may need to be removed and cleaned as illustrated in the troubleshooting web site.

Please let me know what you discover.

Sam A.
by Sam A Earned 707 community points in Appliances
October 11th, 2012
Comment
0 votes
Manage My Life
Thanks for the help so far but its from 1999 i have done the trouble shooting on thier website for flooded salt tank everything checks out fine and empties after like 3hrs during the troubleshooting process but then starts flooding again slowly any suggestions
by Manage My Life
October 10th, 2012
Comment
0 votes
Sam A
Thank you for the update on the flooding of the salt storage tank.
Since you have all ready cleaned the nozzle venturi then I would look at the brine valve being stuck in the up position. You may also want to check the drain line to may sure it is not plugged.

Remove the top cover and look at where the rotary valve is attached to the resin tank. Push the bypass valve to turn the water off and then unsnap the retainers to the valve and lift the valve off the resin tank and look for damaged o-rings.

There is also a possibility that the resin tank is split and leaking and this would take about two days to leak into the salt tank.

If the rotary seals inside the valve are rolled then you also could be leaking into the brine well and flooding the tank.

Please let me know what you find out and we can continue to troubleshoot with that information.

I will give you a link to Kenmore water .com to an interactive side that may help you with the troubleshooting.

Sam A.
by Sam A Earned 707 community points in Appliances
October 4th, 2012
Answered in 16 hours
Comment
0 votes
Manage My Life
Yes i have taken the water out twice and still floods
by Manage My Life
October 4th, 2012
Answered in 13 hours
Comment
0 votes
Sam A
Thank you for your question on the operation of the water softener.

You will have to remove the wet salt and then remove the excess water down to about 4 inches from the bottom of the tank.

Once you have the salt removed then you can use a wet dry shop vacuum to remove the water if you do not want to dip it out.

If you do that make sure that you rinse the vacuum very well to remove any salt residue.

Then put the sale back into the salt tank.

Thank you.

Sam A.
by Sam A Earned 707 community points in Appliances
October 4th, 2012
Answered in 13 hours
Comment
0 votes
Manage My Life
The problem with the water softener can be very frustrating. I did some research and found some information for you that I am hoping will help you until your expert answers your question. To better help your expert, I would like to suggest adding your model number. It may take 24-48 hours. I do hope that everything works out.
by Manage My Life
October 3rd, 2012
Answered in 5 minutes
Comment
0 votes
Didn't find what you are looking for? Ask a question