?
Manage My Life

Snow blower hard to start. When it start i sounds like it missing. I change the sparkplug, any other suggestion.

Model 536887990, craftman 9.0 inch.

Tags
Electric Snowblowers
Sign in to answer a question
2 Answers from these members:
Sam A
Thank you for your question on the snow thrower not running smoothly.

Because this is a seasonal engine and it is about ten years old it could have some carburetion problems.

Since you have changed the sparkplug and I will assume you have fresh fuel in the snow-thrower and no fuel was left in the snow-thrower over winter that you may have some carbon built up in the engine head and is causing it to sound like it is misfiring.

Check the sparkplug condition even though you have changed it to see if it is black. If it is black it may be running a little rich and is on the edge of flooding the engine.

Is there any black smoke coming out of the exhaust muffler while it is running?

If this continues you may have to either service the carburetor or remove the head on the engine and clean out the carbon.

Please let me know what you find out and we can continue to troubleshoot the problem.

Sam A.
by Sam A Earned 707 community points in Electric Snowblowers
December 21st, 2012
Answered in 21 hours
Comment
0 votes
Manage My Life
Good morning... I can fully understand your concern regarding this starting issue. I did locate a link that will discuss this situation in greater detail and offers a different perspective that you might not have considered yet. Keep in mind that an expert will be responding within the next two business days if not sooner and will likely offer you more information and instruction. I hope this link will help guide you as to what might wrong with your snow thrower and have a nice day.
by Manage My Life
December 20th, 2012
Answered in 9 minutes
Comment
0 votes
Didn't find what you are looking for? Ask a question