Skip to content
?
Manage My Life

Kenmore Range Vent Hood Model 233.52345590

I recently installed a new Kenmore Range Vent Hood Model 233.52345590. I did not buy it new from sears but rather received it from someone else but it had never been used or installed. I installed the unit at home and here is my problem: The lights work. When I switch the fan on I can hear and feel the motor operating but it does not seem to have enough power to spin the fan. If I start the fan by spinning it, it continues to run great on High. When I turn the fan speed down the fan stops spinning while I can still hear and feel the motor working to spin the fan. Any idea what is going on?

Thank You

Tags
Kenmore , Ranges , Appliances
6 Answers from these members:
Manage My Life
by Manage My Life
September 19th, 2011
Answered in 8 minutes
Comment
0 votes
Manage My Life
by Manage My Life
September 19th, 2011
Answered in 18 minutes
Comment
0 votes
LYLE W.
by LYLE W. Earned 130,236 community points in Kenmore
September 21st, 2011
Comment
0 votes
jerzyst jerzyst
by jerzyst jerzyst Earned 16 community points in Kenmore
October 18th, 2020
Comment
0 votes
jerzyst jerzyst
by jerzyst jerzyst Earned 16 community points in Kenmore
October 18th, 2020
Comment
0 votes
Martin Londono
by Martin Londono Earned 8 community points in Kenmore
March 19th
Comment
0 votes
Want to get updates on new answers?
this question
Answer this question
Didn't find what you are looking for? Ask a question
Get up to
25
% off
On Ranges